Troubleshoot Notifications

Notification not delivered

Symptoms

An expected notification is not received by your system.

Cause

The notification could not be delivered due to an issue during the delivery process.

Resolution

Use Transactions > Notification History in Commerce Assistant to determine whether the notification was sent and whether delivery was successful.

If the Successfully Delivered column is empty, the notification was not delivered successfully.

Notification History does not support resending failed notifications. Instead, use it to identify and troubleshoot issues in your notification endpoint or integration.

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Notification is not sent immediately

Symptoms

A notification is not received immediately after a transaction is completed.

Cause

Notification tasks are processed asynchronously and may be delayed depending on the current system load. Although Cleverbridge provides real-time notifications, they are not always sent immediately after a transaction.

If a delivery attempt fails, Cleverbridge automatically retries the notification every two hours for up to 48 hours (24 attempts).

Resolution

Wait a few minutes and verify whether the notification has been delivered.

If the notification still has not been received, allow time for the automatic retry process before investigating further.

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